[PyCUDA] Fwd: pycude error about importError: No module named _driver

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[PyCUDA] Fwd: pycude error about importError: No module named _driver

Hilary L
Dear all,

I a newer to install pycuda on windows 10, 64bit, with python 2.7 version, and GPU is NVIDIA MX150.
Firstly, I have installed the vcforpython27 to compile c++ (vs2008), and then I installed CUDA 3.2. After that, I installed the boost (boost_1_67_0).
Then, I have tried to installed pycuda-0.94.2, but there are several errors, shown below.
image.png

Secondly, I installed pycuda-2018.1.1, and it seemed installed successfully, shown below.
image.png
But when I test it, it comes to be some errors, shown below.
image.png


Next, I have tried installing  (pycuda-2014.1+cuda6514-cp27-none-win_amd64.whl) and (pycuda-2018.1+cuda92148-cp27-cp27m-win_amd64.whl). These two versions can be installed successfully, shown below.
image.png

And also, when I test it, it comes to the similar error like the previous one.
image.png

I have search google for these errors and someone suggests to send email for help.
I am looking forward to your kindly help.
Thank you all.

Best wishes,
Hilary 


_______________________________________________
PyCUDA mailing list
[hidden email]
https://lists.tiker.net/listinfo/pycuda
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: pycude error about importError: No module named _driver

Andreas Kloeckner
Hilary,

Hilary L <[hidden email]> writes:

> I a newer to install pycuda on windows 10, 64bit, with python 2.7 version,
> and GPU is NVIDIA MX150.
> Firstly, I have installed the vcforpython27 to compile c++ (vs2008), and
> then I installed CUDA 3.2. After that, I installed the boost (boost_1_67_0).
> Then, I have tried to installed pycuda-0.94.2, but there are several
> errors, shown below.
> [image: image.png]
>
> Secondly, I installed pycuda-2018.1.1, and it seemed installed
> successfully, shown below.
> [image: image.png]
> But when I test it, it comes to be some errors, shown below.
> [image: image.png]
>
>
> Next, I have tried installing
> (pycuda-2014.1+cuda6514-cp27-none-win_amd64.whl) and
> (pycuda-2018.1+cuda92148-cp27-cp27m-win_amd64.whl). These two versions can
> be installed successfully, shown below.
> [image: image.png]
>
> And also, when I test it, it comes to the similar error like the previous
> one.
> [image: image.png]
>
> I have search google for these errors and someone suggests to send email
> for help.
> I am looking forward to your kindly help.
The likely issue is that PyCUDA can't find the CUDA driver
interface. You may use "Dependency Walker" on "_driver.pyd" to see what
it's trying to find. Installing CUDA from Nvidia's download page should
get you on your way.

HTH,
Andreas

_______________________________________________
PyCUDA mailing list
[hidden email]
https://lists.tiker.net/listinfo/pycuda

signature.asc (847 bytes) Download Attachment